Задать вопрос
6 ноября, 04:59

Составить программу, проверяющую есть ли цифра n в числе, введённом с клавиатуры. Pascal abc.

(не копируйте с других источников, неправильно)

+4
Ответы (1)
  1. 6 ноября, 06:29
    0
    Program n1;

    var a, n: integer;

    f: byte;

    begin

    f:=0;

    readln (a, n) ;

    while a0 do

    begin

    if a mod 10=n then f:=1;

    a:=a div 10;

    end;

    if f=1 then write ('цифра ', n,' присутствует в числе')

    else write ('в числе нет цифры ', n) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, проверяющую есть ли цифра n в числе, введённом с клавиатуры. Pascal abc. (не копируйте с других источников, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы