Задать вопрос
24 мая, 22:37

Функция. напишите программу для нахождения наибольшего числа из 5 чисел. Для сравнения двух чисел создать соответствующую функцию

+2
Ответы (1)
  1. 25 мая, 01:17
    0
    Function Max (a, b:real) : real;

    begin

    if a>b then Max:=a

    else Max:=b

    end;

    var

    a, b, c, d, e, m:real;

    i:integer;

    begin

    Writeln ('Введите 5 чисел: ') ;

    Read (a, b, c, d, e) ;

    m:=Max (a, b) ;

    m:=Max (m, c) ;

    m:=Max (m, d) ;

    m:=Max (m, e) ;

    Writeln ('Максимум: ', m)

    end.

    Пример

    Введите 5 чисел:

    2.3 4 - 5.16 0 0.087

    Максимум: 4
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Функция. напишите программу для нахождения наибольшего числа из 5 чисел. Для сравнения двух чисел создать соответствующую функцию ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы