Задать вопрос
23 сентября, 15:55

У школьников было S рублей. Бутылка с соком стоит P рублей, пустая бутылка стоит B рублей. Напишите программу, вычисляющую, сколько бутылок сока могут выпить ученики, если они сдают пустые бутылки и на вырученные деньги и на деньги, оставшиеся от предыдущей покупки, покупают бутылки с соком. (На Паскале)

+5
Ответы (1)
  1. 23 сентября, 17:14
    0
    program zadacha_1;

    var

    s, p, b : real;

    n : integer;

    begin

    n : = 0;

    writeln ('Введите количество денег у школьника пример: (10.00) ') ;

    read (s) ;

    writeln ('Введите стоимость сока пример: (10.00') ;

    read (p) ;

    writeln ('Введите стоимость бутылки пример: (10.00') ;

    read (b) ;

    while s>=p do

    begin

    n : = n + 1;

    s : = s - p;

    s : = s + b;

    end;

    writeln ('Можно купить ', n, ' бутылок сока.') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «У школьников было S рублей. Бутылка с соком стоит P рублей, пустая бутылка стоит B рублей. Напишите программу, вычисляющую, сколько бутылок ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы