Задать вопрос
10 апреля, 15:42

Спортсмен, начав тренировки, в первый день пробежал 10 км. Каждый следующий день он увеличивал дистанцию на 12 %. Написать программу, определяющую общую длину пробега за месяц и первый день с начала тренировок, после которого дистанция превысит 25 км.

паскаль!

+5
Ответы (1)
  1. 10 апреля, 18:21
    0
    const

    D: real = 10; / / число км в день

    p: real = 1.12; / / %

    M: integer = 30; / / число дней в месяце

    N: integer = 25; / / макс дистанция в условии задачи

    var c: integer;

    s, x: real;

    begin

    x : = D;

    for c : = 1 to M do begin

    s : = s + x;

    x : = x * p;

    end;

    writeln ('в месяц пробегает: ', s) ;

    x : = D; c : = 0;

    while (x < N) do begin

    c : = c + 1;

    x : = x * p;

    end;

    writeln ('Нужно ', c, ' дней') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Спортсмен, начав тренировки, в первый день пробежал 10 км. Каждый следующий день он увеличивал дистанцию на 12 %. Написать программу, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы