Задать вопрос
16 сентября, 17:49

Решето Эратосфена в PascalABC

Данные вводятся с клавиатуры или из файла input. txt, выводятся на экран или в файл output. txt. Первые тесты не всегда совпадают с примерами из условия.

Напишите программу, которая выводит все простые числа в диапазоне от 2 до N включительно (2 ≤ N ≤ 100000).

Входные данные

Входная строка содержит целое число N (2 ≤ N ≤ 100000).

Выходные данные

Программа должна вывести все простые числа в диапазоне от 2 до N в одну строку, разделив их пробелами.

Примеры

Входные данные: 20

Выходные данные: 2 3 5 7 11 13 17 19

+5
Ответы (1)
  1. 16 сентября, 19:59
    0
    Program n1;

    var n, i: longint;

    function simply (a: longint) : boolean;

    var i: longint;

    begin

    simply:=true;

    for i:=2 to trunc (sqrt (a)) do begin if a mod i=0 then begin

    simply:=false;

    break

    end

    end

    end;

    begin

    readln (n) ;

    for i:=2 to n do if simply (i) then write (i,' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Решето Эратосфена в PascalABC Данные вводятся с клавиатуры или из файла input. txt, выводятся на экран или в файл output. txt. Первые тесты ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы