Задать вопрос
20 февраля, 13:16

Помогите составить программу на языке паскаль

S=2+4+6 ... + n

+1
Ответы (2)
  1. 20 февраля, 13:53
    0
    Var

    i, n, s:longint;

    begin

    Write ('Введите четное значение последнего члена ряда: ') ;

    Readln (n) ;

    s:=0;

    for i:=1 to n div 2 do s:=s+2*i;

    Writeln ('Сумма членов ряда равна ', s)

    end.

    Тестовое решение:

    Введите четное значение последнего члена ряда: 50

    Сумма членов ряда равна 650
  2. 20 февраля, 16:02
    0
    Var s, i, n: integer;

    begin

    read (n) ;

    i:=2;

    write ('S = ') ;

    while (i<=n) do

    begin

    s:=s+i;

    i:=i+2;

    end;

    writeln (s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите составить программу на языке паскаль S=2+4+6 ... + n ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы