Задать вопрос
26 февраля, 00:00

Дан массив a состоящий из 30 целых чисел - рост 30 учеников школы. Сколько из них имеет рост больше 170 см? Можно ли сформировать баскетбольную команду (в команде должно быть не менее пяти человек ростом больше 170 см) ?

Формат входных данных

На единственной строке через пробел записаны 30 целых чисел (100≤ai≤220) (100≤ai≤220) - росты учеников.

Формат выходных данных

Требуется в первой строке вывести единственное число - количество учеников, рост которых не меньше 170.

На следующей строке вывести "YES", если баскетбольную команду набрать можно, иначе вывести "NO".

+2
Ответы (1)
  1. 26 февраля, 00:41
    0
    Var

    i, c: integer;

    ar: array[1 ... 30]of integer;

    begin

    c : = 0;

    for i : = 1 to 30 do begin

    read (ar[i]) ;

    if (ar[i] > 170) then c : = c + 1;

    end;

    writeln (c) ;

    if (c > = 5) then write ('YES')

    else write ('NO') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан массив a состоящий из 30 целых чисел - рост 30 учеников школы. Сколько из них имеет рост больше 170 см? Можно ли сформировать ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы