Задать вопрос
8 июня, 15:56

1. Сформулировать задачу, решение которой содержало бы данный фрагмент. Записать программу полностью.

for i:=1 to 8 do

begin

b[i] : = a[i]*a[i];

write (b[i], ' ')

end.

2. Составить программу для решения задачи.

Дан массив из 9 натуральных чисел. Составить программу, которая проверяет, является ли каждый элемент массива нечетным числом.

+1
Ответы (1)
  1. 8 июня, 18:53
    0
    1. Дан массив a, состоящий из 8 элементов. Получить массив b, в котором b[i] = a[i]*a[i] (1 < = i <=8).

    var a, b:array[1 ... 8] of integer;

    i:integer;

    begin

    writeln ('a:') ;

    for i:=1 to 8 do

    begin

    a[i] : = random (10) ;

    write (a[i], ' ')

    end;

    writeln;

    writeln ('b:') ;

    for i:=1 to 8 do

    begin

    b[i] : = a[i]*a[i];

    write (b[i], ' ')

    end;

    end.

    Пример:

    a:

    2 9 7 5 2 0 8 7

    b:

    4 81 49 25 4 0 64 49

    2.

    var a:array[1 ... 9] of integer;

    i:integer;

    begin

    writeln ('a:') ;

    for i:=1 to 9 do

    begin

    a[i] : = random (50) + 10;

    write (a[i], ' ')

    end;

    writeln;

    for i:=1 to 9 do

    if a[i] mod 2 = 0

    then writeln (a[i], ' - четное число')

    else writeln (a[i], ' - нечетное число')

    end.

    Пример:

    a:

    55 51 18 35 33 56 15 56 47

    55 - нечетное число

    51 - нечетное число

    18 - четное число

    35 - нечетное число

    33 - нечетное число

    56 - четное число

    15 - нечетное число

    56 - четное число

    47 - нечетное число
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. Сформулировать задачу, решение которой содержало бы данный фрагмент. Записать программу полностью. for i:=1 to 8 do begin b[i] : = ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы