Задать вопрос
15 сентября, 12:46

Введите строку. Удалить все символы, расположенные между круглыми скобками. (Примечание, В строке скобки расставлены правильно, нет вложенных скобок. Может быть несколько пар круглых скобок)

+4
Ответы (1)
  1. 15 сентября, 16:26
    +2
    Var

    s:string;

    i, n, k:integer;

    begin

    Write ('Введите выражение: ') ; Readln (s) ;

    i:=Length (s) ;

    while i>0 do begin

    if s[i]=') ' then begin

    k:=0; Dec (i) ;

    while (s[i]' (') and (i>0) do

    begin Dec (i) ; Inc (k) end;

    Delete (s, i+1, k)

    end;

    Dec (i)

    end;

    Writeln (s)

    end.

    Тестовое решение:

    Введите выражение: 3 * (a+b) / (a-b) ;

    3 * () / () ;
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Введите строку. Удалить все символы, расположенные между круглыми скобками. (Примечание, В строке скобки расставлены правильно, нет ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Новые вопросы по информатике
1) найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2) вывести на экран натуральные нечетные числа от 5 до 55. тоже паскаль 3) найти произведение последовательных натуральных чисел от n до m.
Ответы (1)
Составить блок-схему и программу решения следующей задачи: мальчик взял деньги на мелкие расходы в размере X руб. Из них Y руб он истратил на сладости. Вычислите, сколько денег у него осталось
Ответы (1)
Есть 3 сосуда. Первый вмещяет 12 литров, 2 - 6 и 3 - 4 Как сделать так чтобы в 1 и 2 сосуде было по 6 литров?
Ответы (2)
С помощью одного нажатия какой клавиши на клавиатуре можно нарисовать квадрат в paint?
Ответы (1)
Трое судей используют электрическую схему тайного голосования. решение принимается в том случае, если проголосовало большинство. составить соответствующее логическое выражение. У кого сохранилось решение. Помогите
Ответы (1)