Задать вопрос
26 декабря, 02:05

На день рождения Илья пригласил друзей. На праздничный стол поставили большой прямоугольный торт со сторонами A и B. Илья, известный всем своими причудами решил разделить торт следующим образом: он разрезал торт на равные квадратные куски максимальной площади. Квадратные куски торта раздал гостям, а сам взял то, что осталось. Сколько гостей смог угостить Илья?

Входные данные:

Во входной строке заданы два целых числа A и B (0 < A, B < 30000; A < B)

Выходные данные:

Вывести единственное целое число.

Пример входного файла (input. txt) :

10 100

+3
Ответы (1)
  1. 26 декабря, 03:19
    0
    Var

    A, B, x: integer;

    f: Text;

    begin

    Assign (f, 'input. txt') ;

    Reset (f) ;

    read (f, p) ;

    Close (f) ;

    x : = B div A;

    writeln (x)

    end.

    Тестовое решение:

    10
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «На день рождения Илья пригласил друзей. На праздничный стол поставили большой прямоугольный торт со сторонами A и B. Илья, известный всем ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы