Задать вопрос
22 сентября, 18:15

Напишите программу, которая проверяет правильность имени переменной в языке Паскаль. Имя может содержать только латинские буквы (заглавные и строчные), цифры и знак подчёркивания, но не может начинаться с цифры.

Входные данные

На вход программы подаётся символьная строка, содержащая имя переменной.

Выходные данные

Программа должна вывести ответ 'YES', если строка представляет собой правильное имя переменной в языке Паскаль, и 'NO', если имя ошибочно.

Примеры

входные данные

Abc123

выходные данные

YES

входные данные

Abc[a!

выходные данные

NO

Pascal ABC 1.8 с использованием множеств

+4
Ответы (1)
  1. 22 сентября, 20:08
    0
    Var s: string;

    i: integer;

    good: boolean;

    begin

    readln (s) ;

    good : = True;

    if (s[1] in ['0' ... '9']) then

    good : = False

    else

    begin

    for i : = 1 to length (s) do

    if not ((s[i] in ['a' ... 'z']) or (s[i] in ['A' ... 'Z']) or (s[i] in ['0' ... '9']) or (s[i] = '_')) then

    good : = False;

    end;

    if (good) then

    writeln ('YES')

    else

    writeln ('NO') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая проверяет правильность имени переменной в языке Паскаль. Имя может содержать только латинские буквы (заглавные ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы