Задать вопрос
5 марта, 04:21

Дано целое двузначное число x. Составьте программу вычисления суммы и произведения цифр числа х. Значение x ввести с клавиатуры

+4
Ответы (1)
  1. 5 марта, 05:17
    0
    var

    n, p, s, i: integer;

    begin

    s : = 0; p : = 1;

    readln (n) ;

    while n > 0 do

    begin

    i : = n mod 10;

    s : = s + i;

    p : = p * i;

    n : = n div 10;

    end;

    writeln ('Сумма: ', s, ' Произведение:', p) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано целое двузначное число x. Составьте программу вычисления суммы и произведения цифр числа х. Значение x ввести с клавиатуры ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы