Задать вопрос
30 марта, 10:39

Программа должна вывести одно число: максимальное число, оканчивающиеся на 9.

Входные данные: Выходные данные:

3 19

9

19

23

+4
Ответы (1)
  1. 30 марта, 12:03
    0
    Var

    n, max, i, d: integer;

    begin

    readln (n) ;

    max : = 0;

    for i : = 1 to n do

    begin

    readln (d) ;

    if (d mod 10 = 9) and ((max < d) or (max = 0)) then

    max : = d;

    end;

    writeln (max) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Программа должна вывести одно число: максимальное число, оканчивающиеся на 9. Входные данные: Выходные данные: 3 19 9 19 23 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы