Задать вопрос
27 декабря, 21:24

1) Составьте программу на языке Pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения элементов массива с противоположным знаком.

2) Составьте программу на языке Pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения первой половины элементов увеличенных в 2 раза, а второй половины элементом уменьшенных в 2 раза.

+4
Ответы (1)
  1. 28 декабря, 00:53
    0
    1)

    var

    mas: array [1 ... 10] of integer;

    i:integer;

    begin

    for i:=1 to 10 do

    read (mas[i]) ;

    for i:=1 to 10 do begin

    if mas[i]<0 then

    write (abs (mas[i]),' ')

    else

    write (-mas[i],' ') ;

    end;

    end.

    2)

    var

    mas: array [1 ... 10] of real;

    i:integer;

    begin

    for i:=1 to 10 do

    read (mas[i]) ;

    for i:=1 to 5 do

    write (mas[i]*2,' ') ;

    for i:=6 to 10 do

    write (mas[i]/2,' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) Составьте программу на языке Pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы