Задать вопрос
7 марта, 06:59

1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа.

2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа.

3. Для заданного действительного числа К вычислить значение произведения

(99/k^3-98) * (97/k^3+96) * (95/k^3-94) * ... * (3/k^3+2)

+5
Ответы (1)
  1. 7 марта, 10:58
    0
    1. var a, s:integer;

    begin

    writeln ('введи 3-значное число') ;

    readln (a) ;

    if (a>99) and (a<1000) then begin

    while a>0 do

    begin

    s:=s+sqr (a mod 10) ;

    a:=a div 10;

    end;

    writeln (s) ;

    end else writeln ('Ошибка ввода') ;

    end.

    2. var a, s, k:longint;

    begin

    writeln ('введи 8-значное число') ;

    readln (a) ;

    if (a>9999999) and (a<100000000) then begin

    while a>0 do

    begin

    k: = a mod 10;

    s:=s-k*k*k;

    a:=a div 10;

    end;

    writeln (s) ;

    end else writeln ('Ошибка ввода') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы