Задать вопрос
13 марта, 15:29

Из матрицы У (k, k) получить вектор Т, элементами которого являются элементы главной диагонали матрицы. напишите программу в паскаль

+3
Ответы (1)
  1. 13 марта, 18:32
    0
    Const n=4;

    var y : array[1 ... n, 1 ... n] of integer;

    t : array[1 ... n] of integer;

    i, j : integer;

    begin

    Randomize;

    for i:=1 to n do

    begin

    for j:=1 to n do

    begin

    y[i, j]:=random (20) - 10;

    write (y[i, j]:4) ;

    end;

    writeln;

    end;

    for i:=1 to n do t[i]:=y[i, i];

    writeln ('Полученный массив:') ;

    for i:=1 to n do write (t[i]:5) ;

    writeln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Из матрицы У (k, k) получить вектор Т, элементами которого являются элементы главной диагонали матрицы. напишите программу в паскаль ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы