Задать вопрос
3 июня, 19:18

Определить кол-во нечетных цифр в числе

+5
Ответы (1)
  1. 3 июня, 21:12
    0
    Var k, x:integer;

    begin

    k:=0;

    writeln ('Введите число x') ;

    read (x) ;

    while x>0 do begin

    if x mod 10 mod 20 then k:=k+1;

    x:=x div 10;

    end;

    writeln (k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Определить кол-во нечетных цифр в числе ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
поставьте знаки арифметических операций в каждой схеме. А) скорость? время=путь б) путь? время=скорость в) масса 1 батона? количество батонов=общ. масса г) кол. батонов? кол. буханок=общ. кол. д) кол. конфет в 1 коробке? кол. коробок = общ. кол.
Ответы (1)
Паскаль, цикл с предусловием while. Вводится целое положительное число. Найти наименьшую нечетную цифру в числе. Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр"
Ответы (1)
Вводится целое положительное число. Найти наименьшую нечетную цифру в числе. Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр"
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)