Задать вопрос
14 ноября, 20:08

Ученики школы № 100 любят загадывать загадки. Один ученик задумал два целых числа от 0 до 1000 и сообщил вам их сумму и их произведение. Напишите программу, угадывающую задуманные числа.

+2
Ответы (1)
  1. 14 ноября, 23:55
    0
    Var s, p, a, b: integer;

    begin

    readln (s, p) ;

    a:=round ((s+sqrt (s*s-4*p)) / 2) ;

    b:=s-a;

    writeln (a,' ', b) ;

    end.

    Пример:

    73 1200

    48 25
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Ученики школы № 100 любят загадывать загадки. Один ученик задумал два целых числа от 0 до 1000 и сообщил вам их сумму и их произведение. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы