Задать вопрос
29 мая, 10:14

Написать программу для решение задачи - посчитать количество чисел от 1 до 1000 кратных 7 и честных (провереть кратность 7 командой mod введя условие если в цикл)

+2
Ответы (2)
  1. 29 мая, 10:42
    0
    Var

    count, i:integer;

    begin

    i:=0; count:=0;

    repeat

    i:=i+2;

    if i mod 7 = 0 then count:=count+1;

    until i>=1000;

    writeln (count) ;

    end.
  2. 29 мая, 12:02
    0
    Var

    x, i, y:integer;

    begin

    for i:=1 to 1000 do

    begin

    x: = i mod 7;

    if x=0 then

    begin

    y:=y+1;

    writeln (i) ; / / строка выводит все числа кратные семи. она подлежит удалению

    end;

    end;

    writeln (y) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу для решение задачи - посчитать количество чисел от 1 до 1000 кратных 7 и честных (провереть кратность 7 командой mod ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы