Задать вопрос
12 апреля, 06:57

Напишите программу в Pascal ABC в которой нужно определить номера строк двухмерного массива 5 х3, содержащего только положительные элементы

+2
Ответы (1)
  1. 12 апреля, 07:39
    0
    Const n=5

    var

    a:array [1 ... n, 1 ... n] of integer;

    d:array [1 ... n] of integer;

    i, j:integer;

    begin

    for i:=1 to 5 do

    for j:=1 to 3 do

    readln (a[i, j]) ;

    for i:=1 to 5 do begin

    for j:=1 to 3 do begin

    if a[i, j]>0 then

    d[i]:=d[i]+1;

    end;

    if d[i]=3 then

    d[i]:=i

    else

    d[i]:=0;

    end;

    for i:=1 to 5 do

    if d[i]>0 then

    writeln (d[i]) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу в Pascal ABC в которой нужно определить номера строк двухмерного массива 5 х3, содержащего только положительные элементы ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы