Задать вопрос
7 мая, 15:37

Помогите написать программу в Паскаль.

Дан произвольный текст. Преобразовать его по следующим правилам: все буквы "о" заменяются на "оа", все пробелы заменяются символом "_", а запятые удаляются.

+2
Ответы (1)
  1. 7 мая, 17:08
    0
    S - переменная текста

    i - счетчик

    readln (s) ;

    for i: = 1 to length (s) do

    begin

    if (s[i]='о') then

    s[i]:='оа';

    if (s[i]=' ') then

    (s[i]='_')

    if (s[i]=',') then

    s[i]:='';

    writeln (s) ;

    end.

    Вроде как-то так
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу в Паскаль. Дан произвольный текст. Преобразовать его по следующим правилам: все буквы "о" заменяются на "оа", ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы