Задать вопрос
7 декабря, 17:09

Дано натуральное трёхзначное число n. Найдите сумму и произведение цифр в нём.

Формат входных данных

Вводится целое число n (100≤n≤999)

Формат выходных данных

Требуется вывести сумму и произведение его цифр через пробел.

+4
Ответы (1)
  1. 7 декабря, 19:47
    0
    Можно сделать очень просто, введи каждую цифру данного трехзначного числа отдельно и совершай с ними все арифметические операции.

    Uses Crt;

    Var a, b, c, s, p:integer;

    Begin

    ClrScr;

    writeln ('Введи трехзначное число') ;

    readln (a, b, c) ; {После ввода каждой цифры жми Enter}

    s:=0; s:=a+b+c;

    p:=1; p:=a*b*c;

    writeln ('Сумма цифр s = ', s:5, 'Произведение цифр p = ', p:7) ;

    readkey

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано натуральное трёхзначное число n. Найдите сумму и произведение цифр в нём. Формат входных данных Вводится целое число n (100≤n≤999) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы