Задать вопрос
24 мая, 07:47

Паскаль, помогите!

Ввести с клавиатуры 20 элементов чисел массива, все отрицательные умножить на - 5 все положительные умножить на 20 и 0 заменить числом 1000

+1
Ответы (1)
  1. 24 мая, 08:22
    0
    Program n1;

    Uses CRT;

    Const n=20;

    Var a: array[1 ... n] of integer;

    i: integer;

    begin

    ClrScr;

    Writeln ('Vvedite massiv') ;

    For i:=1 to n do

    readln (a[i]) ;

    For i:=1 to n do

    If a[i]<0 then a[i]:=a[i] * (-5)

    else if a[i]>0 then a[i]:=a[i]*20

    else a[i]:=1000;

    For i:=1 to n do

    write (a[i]:5) ;

    readln

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Паскаль, помогите! Ввести с клавиатуры 20 элементов чисел массива, все отрицательные умножить на - 5 все положительные умножить на 20 и 0 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)