Задать вопрос
6 ноября, 10:37

3. Вычислить значения функции у = sin (n*x) - cos (n/x) при n=1,2, ...,50 и изменении x в интервале [1; 3] c шагом х=0,1. Отпечатать только отрицательные значения функции y.

N эт понятно, а вот как остальное чет вообще не понял.

begin

for N: = 1 to 50 do

writeln (N)

end;

+3
Ответы (1)
  1. 6 ноября, 12:16
    0
    Var

    n:integer;

    x, y:real;

    begin

    for n:=1 to 50 do begin

    Writeln ('n=', n) ;

    x:=1;

    while x<=3.001 do begin

    y:=sin (n*x) - cos (n/x) ;

    if y<0 then Writeln ('x=', x:3:1,' y=', y:8:5) ;

    x:=x+0.1

    end

    end

    end.

    Результаты (частично)

    n=1

    x=2.1 y=-0.02554

    x=2.2 y=-0.08996

    x=2.3 y=-0.16126

    x=2.4 y=-0.23898

    x=2.5 y=-0.32259

    x=2.6 y=-0.41144

    x=2.7 y=-0.50481

    x=2.8 y=-0.60191

    x=2.9 y=-0.70188

    x=3.0 y=-0.80384

    n=2

    x=1.5 y=-0.09412

    x=1.6 y=-0.37370

    x=1.7 y=-0.63973

    x=1.8 y=-0.88619

    x=1.9 y=-1.10714

    x=2.0 y=-1.29710

    x=2.1 y=-1.45132

    x=2.2 y=-1.56607

    x=2.3 y=-1.63885

    x=2.4 y=-1.66858

    x=2.5 y=-1.65563

    x=2.6 y=-1.60190

    x=2.7 y=-1.51073

    x=2.8 y=-1.38683

    x=2.9 y=-1.23607

    x=3.0 y=-1.06530

    ...

    n=49

    x=1.0 y=-1.25435

    x=1.1 y=-1.31878

    x=1.3 y=-0.23684

    x=1.5 y=-1.26149

    x=1.6 y=-0.56383

    x=1.9 y=-1.70385

    x=2.0 y=-1.37979

    x=2.4 y=-0.98177

    x=2.5 y=-0.70927

    x=2.6 y=-0.01366

    x=2.7 y=-0.41812

    x=2.8 y=-1.07678

    x=2.9 y=-0.29265

    n=50

    x=1.0 y=-1.22734

    x=1.1 y=-1.09814

    x=1.5 y=-0.04807

    x=1.6 y=-1.98015

    x=2.0 y=-1.49757

    x=2.1 y=-1.21559

    x=2.5 y=-1.02412

    x=2.6 y=-1.85832

    x=2.7 y=-0.85734

    x=3.0 y=-0.14029
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «3. Вычислить значения функции у = sin (n*x) - cos (n/x) при n=1,2, ...,50 и изменении x в интервале [1; 3] c шагом х=0,1. Отпечатать ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Цикл с параметром и шагом - 1 объявляется с использованием конструкции a) for i:=i1 downto i2 do begin ... end; b) repeat begin ... end until (выражение_условие) ; c) for i:=i1 to i2 do begin ... end; d) if (выражение_условие) begin ...
Ответы (1)
В паскале в 3 циклах: for; repeat; white. Вычислить и напечатать значения функции и соответствующие им значения аргументов x, y. z=2xy-2yx при изменении первого аргумента x[-1; 1] с шагом 0.1 и второго аргумента y[2; 2] с шагом 0.2.
Ответы (1)
Записать в виде обычной математической формулы 1) y:=2*sin (x) * sqrt (x+sqrt (abs (x))) 2) y: = sqrt (sin (x) + sin (sqrt (x))) 3) y: = sqrt (abs (x-1) + sqrt (sin (x))) 4) y: = (5*sin (x) + 4) / 2*15*sin (sqrt (x)) 5) k+15*x / (2*sin (x)) 6) y:=
Ответы (1)
Program z17; const n = 60; var c: array [1 ... n] of integer; k, i:integer; Begin randomize; k:=0; for i:=1 to n do c: = random (21) - 10; if i mod 4 = 0 then if c=0 then k:=k+c[i]; end; end; end; writeln (k) ; end.
Ответы (1)
1. Определите сколько раз будет выполняться тело цикла, при вычислении:y=5x+12a на промежутке [-6; 6 ] с шагом 2. 2. Определите сколько раз будет выполняться тело цикла, при вычислении:y=7/12a на промежутке [-2; 1 ] с шагом 0,5. 3.
Ответы (1)