Задать вопрос
25 июня, 19:25

На ленте машины Поста расположен массив из 2n ячеек. Составить программу, по которой машина Поста раздвинет на расстояние в одну ячейку две половины данного массива.

+3
Ответы (1)
  1. 25 июня, 23:15
    0
    Const

    N = 5;

    var

    i: integer;

    a: array[1 ... N * 2 + 1] of integer;

    begin

    writeln ('Исходный массив: ') ;

    for i : = 1 to 2 * N do

    begin

    a[i] : = Random (99) + 1;

    write (a[i] : 5) ;

    end;

    for i : = 2 * N + 1 downto N + 1 do

    a[i] : = a[i - 1];

    a[N + 1] : = 0;

    writeln () ;

    writeln ('Полученный массив: ') ;

    for i : = 1 to 2 * N + 1 do

    write (a[i] : 5) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «На ленте машины Поста расположен массив из 2n ячеек. Составить программу, по которой машина Поста раздвинет на расстояние в одну ячейку две ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы