Задать вопрос
8 января, 08:25

Написать программу к задаче: Дано число. Найти сумму и произведение его цифр.

+3
Ответы (1)
  1. 8 января, 11:17
    0
    Program n1;

    var n, sum, p: integer;

    begin

    readln (n) ;

    sum:=0;

    p:=1;

    while n0 do

    begin

    sum:=sum+n mod 10;

    p:=p * (n mod 10) ;

    n: = n div 10;

    end;

    writeln ('сумма цифр: ', sum) ;

    write ('произведение: ', p) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу к задаче: Дано число. Найти сумму и произведение его цифр. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы