Задать вопрос
1 апреля, 16:15

Задание: Составьте программу ввода с клавиатуры элементов массива a[1 ... 10] и вывода на экран элементов, значения которых являются квадратами целых чисел. Вот что я составил, но извлечение корня нельзя делать в integer: (Помогите! Program shist;

Var a: array [1 ... 10] of integer;

i: integer;

Begin

writeln ('ВВедите элементы массива:') ;

readln (i) ;

writeln ('Элементы массива, значения которых являются квадратами целых чисел:') ;

For i:=1 to 10 do

if sqrt (i) then

write (a[i], ' ')

End.

+5
Ответы (1)
  1. 1 апреля, 16:47
    0
    Текст программы на языке Паскаль:

    program _1;

    const N=10;

    var i: integer;

    a: array[1 ... N] of integer;

    begin

    for i:=1 to N do begin

    readln (a[i]) ;

    a[i]:=a[i]*a[i];

    end;

    for i:=1 to N do begin

    writeln (a[i]) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задание: Составьте программу ввода с клавиатуры элементов массива a[1 ... 10] и вывода на экран элементов, значения которых являются ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы