Задать вопрос
15 марта, 14:40

Клавиатуры вводится трёхзначное число. Нужно вывести ответ "Да", если все его цифры четные, и ответ "Нет" в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение "Неверное число".

+4
Ответы (1)
  1. 15 марта, 15:07
    0
    Var chislo, x, i, s: integer;

    begin

    writeln ('Введите число:') ;

    readln (chislo) ;

    x : = chislo;

    s : = 0;

    if (chislo 999) then writeln ('Неверное число!')

    else begin

    while (x 0) do begin

    s : = s + (x mod 10) ;

    x : = x div 10;

    end;

    if s mod 2 = 0 then write ('Да')

    else write ('Нет') ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Клавиатуры вводится трёхзначное число. Нужно вывести ответ "Да", если все его цифры четные, и ответ "Нет" в остальных случаях. Если введено ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
С клавиатуры вводится трёхзначное число. Нужно вывести ответ "Да", если все его цифры четные, и ответ "Нет" в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение "Неверное число".
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
Напишите программу, которая принимает с клавиатуры числа, пока не будет введено значение 999. Программа должна подсчитать, сколько значений было введено с клавиатуры (не считая значения 999) и вывести эту информацию на экран.
Ответы (1)