Задать вопрос
18 декабря, 15:05

Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю"

задача 2 - дано целое число. Если число положительное, то вывести его на печать. иначе вывести " Данное число не является положительным ".

задача 3 - Даны два числа. Вывести сначала меньшее. затем большее число.

задача 4 - Даны два числа. Вывести порядковый номер меньшего числа.

задача 5 - Дано целое число. Если число положительное, то вывести его на печать. Если отрицательное, вывести число, умноженное на - 1.

задача 6 - Найдите наименьшее из трех заданных чисел

+1
Ответы (1)
  1. 18 декабря, 17:20
    0
    1.

    var

    a:integer;

    begin

    write ('Введите целое число : ') ;

    readln (a) ;

    if a>0 then

    writeln ('Число - положительное ') else

    writeln ('Данное число не является положительным ') ;

    if a=0 then

    writeln ('Число равно нулю') ;

    readln;

    end.

    2.

    var

    a:integer;

    begin

    write ('Введите целое число : ') ;

    readln (a) ;

    if a>0 then

    writeln ('Число - положительное ') else

    writeln ('Данное число не является положительным ') ;

    readln;

    end.

    3.

    var

    a, b:integer;

    begin

    write ('Введите два числа : ') ;

    readln (a, b) ;

    if a>b then

    writeln (a,#10, b) else

    writeln (b,#10, a) ;

    readln;

    end.

    4.

    var

    a, b: integer;

    begin

    writeln ('Введите два числа') ;

    readln (a, b) ;

    if a < b then writeln ('Порядковый номер меньшего числа = 1') ;

    if b < a then writeln ('Порядковый номер меньшего числа = 2') ;

    if a = b then writeln ('Числа равны') ;

    end.

    5.

    var

    a:integer;

    begin

    write ('Введите число: ') ;

    readln (a) ;

    if a>0 then

    writeln (a) ;

    if a<0 then

    writeln (a*-1) ;

    readln;

    end.

    6.

    var

    a, b, c, n:real;

    begin

    writeln ('Введите три числа : ') ;

    readln (a, b, c) ;

    n:=a;

    if b
    n:=b;

    if c
    n:=c;

    writeln ('Меньшее из введённых чисел : ', n) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы