Задать вопрос
22 марта, 05:29

Даны координаты противопложных вершин прямоугольника х1 у1 х2 у2 стороны прямоугольника парралельны осям координата координат * составьте программу вычесления периметра и площади прямоугольника

+5
Ответы (1)
  1. 22 марта, 06:18
    0
    На паскале:

    var x1, x2, x3, y1, y2, y3, ax, bx, ay, by, a, b, p, s:integer;

    begin

    readln (x1) ; readln (y1) ; readln (x2) ; readln (y2) ;

    x3:=x1; y3:=y2; / / координаты 3 точки

    ax:=x1-x3; ay:=y1-y3; bx:=x2-x3; by:=y2-y3; / / координаты направляющих векторов

    a:=sqrt (sqr (ax) + sqr (ay)) ; / / длинна вектора

    b:=sqrt (sqr (bx) + sqr (by)) ; / / длинна вектора

    p:=2 * (a+b) ; / / периметр

    s:=a*b; / / площадь

    writeln (p) ;

    writeln (s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Даны координаты противопложных вершин прямоугольника х1 у1 х2 у2 стороны прямоугольника парралельны осям координата координат * составьте ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы