Задать вопрос
12 ноября, 09:36

Напишите программу, которая генерирует массив из случайных чисел от 20 до 85 в количестве не более 30 чисел. После этого необходимо посчитать количество чисел, больших введенного вами с клавиатуры.

Hellp решает игоговую оценку

+3
Ответы (1)
  1. 12 ноября, 12:26
    0
    Program n1;

    const n=15;

    var a: array[1 ... n] of integer;

    i, b, k: integer;

    begin

    randomize;

    write ('массив: ') ;

    for i:=1 to n do begin

    a[i]:=random (66) + 20;

    write (a[i],' ') ;

    end;

    writeln;

    write ('введите число: ') ;

    readln (b) ;

    k:=0;

    for i:=1 to n do if a[i]>b then k:=k+1;

    write ('k=', k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая генерирует массив из случайных чисел от 20 до 85 в количестве не более 30 чисел. После этого необходимо ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы