Задать вопрос
14 марта, 20:21

Написать программу, которая по заданной дате (числу d и месяцу m) определяет число дней, прошедших от начала года, если известно, что год - не високосный.

+1
Ответы (1)
  1. 14 марта, 20:37
    0
    Const Months: Array [1 ... 12] Of Integer = (31,28,31,30,31,30,31,31,30,31,30,31) ;

    var d, m, result, i : integer;

    Begin

    read (d, m) ;

    for i : = 1 to m-1 do

    result : = result + Months[i];

    writeln (result + d) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая по заданной дате (числу d и месяцу m) определяет число дней, прошедших от начала года, если известно, что год - ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Определить количество дней в году, которое вводится пользователем. Алгоритм решения задачи: В високосном году - 366 дней, в обычном 365. Високосными годами являются все года.
Ответы (1)
На с + + Дан номер года. Требуется определить количество дней в этом году, учитывая, что обычный год насчитывает 365 дней, а високосный - - 366 дней.
Ответы (1)
1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Ответы (1)
Написать программу, определяющую количество дней в месяце Алгоритм решения задачи: Переменная d имеет тип данных запись и содержит два поля: year - для хранения года и month - для месяца. Пользователь вводит год и месяц.
Ответы (1)
Дано n-число прошедших дней с начала месяца. Написать программу подсчета количества часов (has), минут (min) и секунд (sec) от начала месяца. входные данные n=5 выходные данные 120 7200 432000
Ответы (1)