Задать вопрос
21 мая, 22:58

Вычислить среднее арифметическое отрицательных элементов вектора Q (21)

p. s. через программу паскаль

+1
Ответы (1)
  1. 21 мая, 23:19
    0
    Const n=21;

    var q:array[1 ... n] of integer;

    i, s, k:integer;

    begin

    Randomize;

    for i:=1 to n do

    begin

    q[i]:=random (51) - 10;

    write (q[i]:4) ;

    end;

    writeln;

    k:=0; s:=0;

    for i:=1 to n do

    if q[i]<0 then begin s:=s+q[i]; k:=k+1; end;

    writeln ('Среднее арифметическое отрицательных элементов = ', s/k) ;

    end.

    Пример:

    16 - 1 - 7 5 13 11 - 2 - 10 36 19 3 34 23 29 12 28 9 39 33 16 - 6

    Среднее арифметическое отрицательных элементов = - 5.2
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Вычислить среднее арифметическое отрицательных элементов вектора Q (21) p. s. через программу паскаль ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1 задача: Массив Z (20) заполнить целыми случайными числами в диапазоне от - 20 до 20. Вычислить CP - среднее арифметическое положительных элементов и CN - среднее арифметическое отрицательных элементов массива Z.
Ответы (1)
Помогите решить через паскаль 1) массив А вводится с клавиатуры, найти среднее арифметическое его элементов с нечетными номерами, размер произвольный.
Ответы (1)
Вычислить X=m / (n-m), где m - сумма квадратов отрицательных элементов первого вектора, n - сумма квадратов отрицательных элементов второго вектора в паскале
Ответы (1)