Задать вопрос
25 сентября, 03:24

Задан вид квадратного уравнения ах квадрат + bx+c=0, коэффициенты a, b, c. Найти корни уравнения x1, x2.

1. Разработать схему алгоритма программы

2. Составить программу на языке Паскаль по разработанному алгоритму

+5
Ответы (1)
  1. 25 сентября, 05:17
    0
    Var a, b, c, d, x1, x2:real;

    begin

    writeln ('Решение квадратных уравнений') ;

    writeln ('') ;

    writeln ('Введите коэффициенты a, b, c:') ;

    readln (a, b, c) ;

    d:=sqr (b) - 4*a*c;

    if d<0 then writeln ('Корней нет') ;

    if d=0 then begin x1:=-b / (2*a) ;

    writeln ('Один корень:') ;

    writeln (x1:4:2) ;

    end;

    if d>0 then begin

    x1:=-b+sqrt (d) / (2*a) ;

    x2:=-b-sqrt (d) / (2*a) ;

    writeln ('Корни уравнения:') ;

    writeln (x1:4:2) ;

    writeln (x2:4:2) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задан вид квадратного уравнения ах квадрат + bx+c=0, коэффициенты a, b, c. Найти корни уравнения x1, x2. 1. Разработать схему алгоритма ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы