Задать вопрос
20 мая, 08:04

Составить программу вычисления максимального и минимального элемента линейного массива состоящего из 14 случайных чисел, принадлежащих диапазону (0; 90]

+3
Ответы (1)
  1. 20 мая, 09:21
    0
    Program PAS;

    Const

    N = 14;

    Var

    A:Array[1 ... N] of integer;

    i, Max, Min:integer;

    Begin

    Randomize;

    Write ('Исходный массив:') ;

    For i: = 1 to N do

    Begin

    A[i]:=random (90) + 1;

    Write (' ', A[i]) ;

    End;

    WriteLn;

    Max:=1;

    Min:=1;

    For i: = 2 to N do

    Begin

    if A[i]>A[Max] then Max:=i;

    if A[i]
    End;

    WriteLn ('Max (A) = A[', Max,'] = ', A[Max]) ;

    WriteLn ('Min (A) = A[', Min,'] = ', A[Min])

    End.

    Пример:

    Исходный массив: 66 70 88 36 30 11 53 1 57 77 6 40 65 46

    Max (A) = A[3] = 88

    Min (A) = A[8] = 1
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу вычисления максимального и минимального элемента линейного массива состоящего из 14 случайных чисел, принадлежащих ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы