Задать вопрос
13 октября, 07:59

Даны целые числа: а, b, и с. Возвести в квадрат те из них, которые положительны.

Входные данные : - 3; 5; -2

Выходные : - 3; 25; -2.

+1
Ответы (2)
  1. 13 октября, 09:27
    0
    Var f: text; s, d:string; i, n:integer; a:array of integer; BeginAssign (f,'c://q/t. txt') ; Reset (f) ; n:=3; setLength (a, n) ; While not eof (f) do begin readln (f, s) ; writeln (i:2,' ', s) ; end; Close (f) ; writeln; var arr : = s. Split ('; ') ; for i:=0 to n-1 do begina[i] : = strtoint (arr[i]) ; if a[i] > 0 then a[i]: = a[i] * a[i]; end;

    for i:=0 to n-1 dod: = d + inttostr (a[i]) + '; ';

    assign (f,'c://q/out. txt') ; rewrite (f) ; write (f, d) ; Close (f) ; end.
  2. 13 октября, 09:40
    0
    Program n1;

    var a, b, c: integer;

    begin

    readln (a, b, c) ;

    if a>0 then write (a*a,' ') else write (a,' ') ;

    if b>0 then write (b*b,' ') else write (b,' ') ;

    if c>0 then write (c*c,' ') else write (c,' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Даны целые числа: а, b, и с. Возвести в квадрат те из них, которые положительны. Входные данные : - 3; 5; -2 Выходные : - 3; 25; -2. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы