Задать вопрос
7 октября, 06:07

В PascalABC

Напишите программу, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), у которых первая и последняя цифры десятичной записи одинаковые.

Входные данные

Входная строка содержит два натуральных числа, разделённые пробелом, K и N (2 ≤ K ≤ N ≤ 100000).

Выходные данные

Программа должна вывести все простые числа, у которых одинаковые первая и последняя цифры десятичной записи, в диапазоне от K до N в одну строку, разделив их пробелами. Если таких чисел нет, нужно вывести число 0.

Примеры

входные данные

100 200

выходные данные

101 131 151 181 191

входные данные

20 30

выходные данные

0

+2
Ответы (1)
  1. 7 октября, 06:14
    0
    Program n1;

    var k, n, i: longint;

    co: byte;

    function simply (a: longint) : boolean;

    var i: longint;

    begin

    simply:=true;

    for i:=2 to trunc (sqrt (a)) do begin if a mod i=0 then begin

    simply:=false;

    break

    end

    end

    end;

    function cr (a: longint) : boolean;

    var n: longint;

    begin

    n:=a;

    cr:=false;

    repeat

    n:=n div 10;

    until n mod 10 = n;

    if n = (a mod 10) then

    begin

    cr:=true;

    end;

    end;

    begin

    readln (k, n) ;

    for i:=k to n do if simply (i) then begin if (i=2) or (i=3) or (i=5) or (i=7) or cr (i) then

    begin

    write (i,' ') ;

    co:=1;

    end

    end;

    if co=0 then write (0) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В PascalABC Напишите программу, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), у которых первая и последняя ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы