Задать вопрос
29 июля, 10:57

составить программу которая будет находить сумму отрицательных чётных элементов одномерного массива. используя процедуры

+1
Ответы (1)
  1. 29 июля, 14:22
    0
    Var

    i, s:integer;

    a:array[1 ... 10]of integer;

    procedure sum (a:integer; var s:integer) ;

    begin

    if (a mod 2=0) and (a<0) then

    s:=s+a

    end;

    begin

    write ('Массив: ') ;

    for i:=1 to 10 do

    begin

    a[i]:=random (-10,10) ;

    write (a[i],' ') ;

    sum (a[i], s)

    end;

    writeln;

    writeln ('s=', s)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «составить программу которая будет находить сумму отрицательных чётных элементов одномерного массива. используя процедуры ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы