Задать вопрос
25 октября, 18:14

Составить программу которая считывает целое число. Если оно чётное и положительно увеличить его в два раз, в противном случае увеличить в 10 раз.

+2
Ответы (1)
  1. 25 октября, 20:08
    0
    C#:

    class Program

    {

    static void Main (string[] args)

    {

    int a;

    a = Convert. ToInt32 (Console. ReadLine ()) ;

    if (a % 2 = = 0)

    {

    a * = 2;

    }

    else

    {

    a * = 10;

    }

    Console. WriteLine (a) ;

    Console. ReadLine () ;

    }

    }

    Pascal:

    program n;

    var

    a: integer;

    begin

    readln (a) ;

    if a mod 2 = 0 then

    a * = 2

    else

    a * = 10;

    writeln (a) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу которая считывает целое число. Если оно чётное и положительно увеличить его в два раз, в противном случае увеличить в ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы