Задать вопрос
5 июня, 04:42

Составить программу на языке Паскаль Ввести с клавиатуры вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 до N.

+4
Ответы (2)
  1. 5 июня, 06:18
    0
    Var

    a: real;

    n: integer;

    begin

    read (a, n) ;

    for var k : = 1 to n do

    begin

    write (power (a, k), ' ') ;

    end;

    end.
  2. 5 июня, 07:46
    0
    Var a, an:real; n, i:integer;

    begin

    readln (a, n) ;

    an:=1;

    for i:=1 to n do

    begin

    an:=an*a;

    writeln (a:3:2,'^', i,' = ', an:6:3) ;

    end;

    end.

    Пример:

    2.0 5

    2.00^1 = 2.000

    2.00^2 = 4.000

    2.00^3 = 8.000

    2.00^4 = 16.000

    2.00^5 = 32.000
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу на языке Паскаль Ввести с клавиатуры вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы