Задать вопрос
16 мая, 09:36

В Тридевятом царстве завершился чемпионат лесорубов.

Правила определения победителя следующие: победителем считается тот лесоруб, который срубил за сутки наибольшее количество деревьев. А если таких лесорубов несколько, то победителем становится тот из них, кто при этом сделал как можно меньше ударов. Известно, что ни у каких двух лесорубов нет абсолютно одинакового результата.

Требуется написать программу, которая принимает на вход список участников, для каждого из которых задано его имя, а также то, сколько деревьев и за какое суммарное количество ударов он срубил, и выводит имя победителя.

+2
Ответы (1)
  1. 16 мая, 12:35
    0
    Var n, pi, ti, max, min, i:integer;

    name, m_name:string;

    begin

    readln (n) ;

    max:=0; min:=5000;

    for i:=1 to n do

    begin

    readln (name) ;

    readln (pi, ti) ;

    if pi>max

    then begin m_name:=name; max:=pi; min:=ti; end

    else if pi=max

    then if ti
    end;

    writeln (m_name) ;

    end.

    Пример:

    4

    John

    10 123

    Ringo

    10 144

    George

    11 156

    Paul

    11 160

    George
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В Тридевятом царстве завершился чемпионат лесорубов. Правила определения победителя следующие: победителем считается тот лесоруб, который ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы