Задать вопрос
14 декабря, 17:44

Дано четырехзначное число, если оно кратно 4, то посчитать сумму его цифр, иначе посчитать произведение цифр. Составить программу на Паскаль

+5
Ответы (1)
  1. 14 декабря, 20:13
    0
    Var a : Integer;

    Begin

    Readln (a) ;

    If a mod 4 = 0 then Writeln ('Сумма цифр: ', a div 1000+a mod 1000 div 100+a mod 100 div 10+a mod 10)

    else Writeln ('Произведение цифр: ', (a div 1000) * (a mod 1000 div 100) * (a mod 100 div 10) * (a mod 10)) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано четырехзначное число, если оно кратно 4, то посчитать сумму его цифр, иначе посчитать произведение цифр. Составить программу на Паскаль ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы