Задать вопрос
13 ноября, 07:12

Составить программу которая формирует массив из 9 случайных целых чисел на промежутке от - 30,30 и вычислите:

а) сумму отрицательных чисел

б) произведение чётных чисел

+1
Ответы (1)
  1. 13 ноября, 10:38
    0
    Var

    mas: array [1 ... 9] of integer;

    summ, count: integer;

    i: integer;

    begin

    randomize;

    summ : = 0;

    count : = 1;

    for i : = 1 to 9 do

    begin

    mas[i] : = random (-30, 30) ;

    write (mas[i] : 4) ;

    if mas[i] < 0 then summ : = summ + mas[i];

    if mas[i] > 0 then count : = count * mas[i];

    end;

    writeln ('') ;

    writeln ('Сумма отрицательных элементов: ', summ) ;

    writeln ('Произведение положительных элементов: ', count) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу которая формирует массив из 9 случайных целых чисел на промежутке от - 30,30 и вычислите: а) сумму отрицательных чисел ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы