Задать вопрос
7 октября, 13:05

В школе продолжительность каждого урока 45 минут, а

перемены между уроками - всего 5 минут. Первый урок начинается ровно в 8 часов

утра. Напишите программу, отвечающую на вопрос "во сколько в этой школе

заканчивается K-ый урок?"

+4
Ответы (1)
  1. 7 октября, 15:03
    0
    uses crt;

    var h, m, k:integer;

    begin

    readln (k) ;

    m: = (45*k) + (5 * (k-2)) ;

    h:=8 + (m div 60) ;

    m:=m mod 60;

    write (h,':', m) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В школе продолжительность каждого урока 45 минут, а перемены между уроками - всего 5 минут. Первый урок начинается ровно в 8 часов утра. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы