Задать вопрос
2 октября, 07:04

Напишите программу на Паскале. Для заданных чисел X и N вычислите Z=X^N=X*X ... X.

X*X ... X=N

+2
Ответы (1)
  1. 2 октября, 10:42
    0
    var

    x, n, x1 : real;

    begin

    readln (x, n) ;

    x1:=abs (x) ;

    if x<0 then writeln (-1*exp (n*ln (x1)) : 0:0)

    else writeln (exp (n*ln (x)) : 0:0) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу на Паскале. Для заданных чисел X и N вычислите Z=X^N=X*X ... X. X*X ... X=N ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы