Задать вопрос
13 декабря, 02:19

1) составить программу, которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный

2-ая Составить программу, которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми

язык паскаль

+2
Ответы (1)
  1. 13 декабря, 03:25
    0
    1) program gt;

    var a:array[1 ... 100,1 ... 100]of integer;

    b:array[1 ... 100]of integer;

    n, m, s, i, j:integer;

    begin

    readln (n, m) ;

    for i:=1 to n do

    for j:=1 to m do

    read (a[i, j]) ;

    for j:=1 to m do

    begin

    s:=0;

    for i:=1 to n do

    s:=s+a[i, j];

    b[j]:=s;

    end;

    for i:=1 to m do

    write (b[i],' ') ;

    end.

    2)

    program gt;

    var a:array[1 ... 100,1 ... 100]of integer;

    n, m, s, i, j:integer;

    begin

    readln (n, m) ;

    randomize;

    for i:=1 to n do

    begin

    for j:=1 to m do

    begin

    if (i mod 2=0) then a[i, j]:=0 else a[i, j]:=random (100) ;

    write (a[i, j],' ') ;

    writeln;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) составить программу, которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный 2-ая Составить ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы