Задать вопрос
25 апреля, 04:35

Написать программу в Паскале, которая определяет сумму натуральных чисел кратных 3 и оканчивающихся на 6. Последнее число последовательности 0. Количество чисел не превышает 1000. Количество введённых чисел неизвестно.

+5
Ответы (1)
  1. 25 апреля, 04:56
    0
    Uses crt;

    var n, i, s: integer;

    a: array [1 ... 1000] of integer;

    begin writeln ('Введите количество чисел последовательности') ;

    read (n) ;

    s : = 0;

    writeln ('Введите числа') ;

    for i : = 1 to n do

    begin

    read (a[i]) ;

    a[n] : = 0;

    end;

    writeln () ;

    for i : = 1 to n do

    write (a[i], ' ') ;

    writeln () ;

    for i : = 1 to n do

    s : = s + a[i];

    writeln ('Сумма=', s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу в Паскале, которая определяет сумму натуральных чисел кратных 3 и оканчивающихся на 6. Последнее число ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы