Задать вопрос
26 февраля, 08:34

Изменение

элементов массива

Дан массив из N положительных элементов, больших 1

(2<=N<=100).

После каждого элемента вставить его минимальный делитель

больший 1.

Формат входных данных:

На входе подаются в первой строке N - число элементов массива

Вторая строка содержит N чисел - значения элементов массива

Формат выходных данных: Выведите результирующий массив в строку

Пример:

Ввод

5

43 50 76 84 100

Вывод

43 43 50 2 76 2 84 2 100 2

+4
Ответы (1)
  1. 26 февраля, 08:48
    0
    Program gt;

    label 1,2;

    var a, b:array[1 ... 1000]of integer;

    n, i, l, j:integer;

    begin

    read (n) ;

    for i:=1 to n do

    begin

    read (a[i]) ;

    l:=round (sqrt (a[i])) ;

    for j:=2 to l do

    begin

    if (a[i] mod j=0) then goto 1;

    end;

    b[i]:=a[i];

    goto 2;

    1:

    b[i]:=j;

    2:

    end;

    for i:=1 to n do

    begin

    write (a[i],' ', b[i],' ') ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Изменение элементов массива Дан массив из N положительных элементов, больших 1 (2 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы