Задать вопрос
16 декабря, 05:05

Напишите программу поиска все двузначных чисел, в которых есть цифра n, или само число делится на n (решите по паскалю).

+5
Ответы (2)
  1. 16 декабря, 06:08
    0
    var

    i, n: integer;

    begin

    readln (n) ;

    for i : = 10 to 99 do

    if (i mod 10 = n) or (i div 10 = n) or (i mod n = 0) then write (i:4) ;

    end.
  2. 16 декабря, 08:11
    0
    Var

    i, n: integer;

    begin

    readln (n) ;

    for i: = 10 to 99 do

    if (i mod 10 = n) or (i div 10 = n) or (i mod n = 0) then writeln (i)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу поиска все двузначных чисел, в которых есть цифра n, или само число делится на n (решите по паскалю). ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы