Задать вопрос
9 января, 09:22

Составьте программу, определяющую максимальный элемент и его индексы матрицы А размером M x N

+5
Ответы (1)
  1. 9 января, 12:04
    0
    Var a:array[1 ... 10,1 ... 10]of integer; неудобно var a:array[1 ... 10,1 ... 10]of integer;

    max, i1, j1, i, j, k, m, n:integer;

    begin

    readln (m, n) ;

    for i:=1 to m do

    for j:=1 to n do

    readln (a[i, j]) ;

    max:=a[1,1];

    i1:=1;

    j1:=1;

    for i:=1 to m do begin

    for j:=1 to n do begin

    if a[i, j]>max then begin max:=a[i, j]; i1:=i; j1:=j; end;

    end;

    end;

    writeln (max,' ', i1,' ', j1) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, определяющую максимальный элемент и его индексы матрицы А размером M x N ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы